Opened 3 months ago

Closed 3 months ago

#35374 closed Bug (invalid)

UniqueConstraint (and potentially other constraints) validation is not run when using a form generated from `inlineformset_factory`

Reported by: David Hang Owned by: nobody
Component: Forms Version:
Severity: Normal Keywords:
Cc: David Hang Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Due to how refactors in Django 4+ on how the unique validations are run for models and forms, an edge case has occured where in an inline form, UniqueConstraint checks which were previously run are now being skipped over and not returning validation errors, which then causing database integrity errors when the form is attempted to be saved.

Reproducible example:

from django.forms import inlineformset_factory
from django import forms
from django.db import models


class Farm(models.Model):
    name = models.CharField(max_length=255)


class Apple(models.Model):
    name = models.CharField(max_length=255)
    farm = models.ForeignKey(Farm, on_delete=models.CASCADE)

    class Meta:
        constraints = [
            models.UniqueConstraint(fields=["name", "farm"], name="unique_apple")
        ]


class AppleForm(forms.ModelForm):
    class Meta:
        model = Apple

        fields = ["name", "farm"]


big_farm = Farm.objects.create(name="Big Farm")
best_apple = Apple.objects.create(name="Best Apple", farm=big_farm)

AppleFormSet = inlineformset_factory(Farm, Apple, AppleForm)

data = {
    "apple_set-TOTAL_FORMS": "2",
    "apple_set-INITIAL_FORMS": "0",
    "apple_set-0-name": "Best Apple",
    "apple_set-0-farm": big_farm.pk,
}

formset = AppleFormSet(data, instance=big_farm)

print(formset.is_valid())
print(formset.errors)

formset.save()

IntegrityError: duplicate key value violates unique constraint "unique_apple"
DETAIL:  Key (name, farm_id)=(Best Apple, 3) already exists.

In normal forms, and formsets, the validation does run correctly. This issue caused by https://github.com/django/django/blob/42bc81b1b6471c4fe364bc32b9dec180908e577e/django/forms/models.py#L486

        # Foreign Keys being used to represent inline relationships
        # are excluded from basic field value validation. This is for two
        # reasons: firstly, the value may not be supplied (#12507; the
        # case of providing new values to the admin); secondly the
        # object being referred to may not yet fully exist (#12749).
        # However, these fields *must* be included in uniqueness checks,
        # so this can't be part of _get_validation_exclusions().
        for name, field in self.fields.items():
            if isinstance(field, InlineForeignKeyField):
                exclude.add(name)

Change History (1)

in reply to:  description comment:1 by Natalia Bidart, 3 months ago

Resolution: invalid
Status: newclosed
Version: 4.1

Hello David! Thank you for your report.

Replying to David Hang:

Due to how refactors in Django 4+ on how the unique validations are run for models and forms

Could you please provide more concrete information about this affirmation? The code you linked hasn't changed in 11 years (except for a switch to use sets instead of lists for the `exclude` variable) so I'm not sure what refactor in Django 4+ you are referring to.

The example that you provided is a bit tricky/incomplete, because the data that is being passed to the formset is incomplete. The data should account for the current status of the Big Farm instance; this is a correct data dict example to be passed to the formset:

data = {
    "apple_set-TOTAL_FORMS": "3",
    "apple_set-INITIAL_FORMS": "1",
    "apple_set-0-name": "Best Apple",
    "apple_set-0-farm": big_farm.pk,
    "apple_set-0-id": best_apple.pk, 
    "apple_set-1-name": "Best Apple",
    "apple_set-1-farm": big_farm.pk,
    "apple_set-1-id": "", 
}

Then, the expected unique validation is performed. The formset is indeed not valid and the errors are:

 [{}, {'__all__': ['Please correct the duplicate values below.']}, {}]

I'll be closing this issue as invalid since it could be that you may be misunderstanding how formsets works. If you need further assistance, there are many user support channels with an amazing community that will surely help you.

Note: See TracTickets for help on using tickets.
Back to Top