Opened 3 months ago

Closed 3 months ago

#35343 closed Bug (invalid)

Found 0 test(s) when ran from parent folder

Reported by: Al Mahdi Owned by: nobody
Component: Testing framework Version: 5.0
Severity: Normal Keywords: test cli
Cc: Al Mahdi Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Al Mahdi)

Running this in the project folder finds all tests in app/tests.py files

python manage.py test

But running this from the parent folder doesn't find any test

python example/manage.py test

Change History (6)

comment:1 by Al Mahdi, 3 months ago

Description: modified (diff)

comment:2 by David Sanders, 3 months ago

Resolution: invalid
Status: newclosed

If you need assistance please seek help from a friendly community member from either the forum or Discord: https://www.djangoproject.com/community/

The issue tracker is for reporting bugs with Django itself. User issues related to Python usage fall outside this unfortunately 🤷‍♂️

comment:3 by Al Mahdi, 3 months ago

Summary: Found 0 test(s) from outside of the projectFound 0 test(s) when ran from parent folder

comment:4 by Al Mahdi, 3 months ago

Description: modified (diff)

in reply to:  2 comment:5 by Al Mahdi, 3 months ago

Resolution: invalid
Status: closednew

Replying to David Sanders:

How come it is not a bug in Django itself.

Maybe the summery and description wasn't clear enough. I have updated them.

Please review it again.

comment:6 by David Sanders, 3 months ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.
Back to Top