Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#35298 closed Bug (invalid)

LANGUAGE_CODE: zh-Hant does not work for some translations on the admin site.

Reported by: 梁耀文 Owned by: nobody
Component: Internationalization Version: 5.0
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by 梁耀文)

I am using LANGUAGE_CODE = zh-Hant and USE_I18N = True on the admin site, but translations for phrases like “start typing to filter…”, “Please correct the errors below.”, “First, enter a username and password. Then, you’ll be able to edit more user options.”, or “Hold down “Control”, or “Command” on a Mac, to select more than one.” do not work properly. However, if I switch to other languages, such as zh-Hans or ja, the translations display correctly (only changing the LANGUAGE_CODE, all other code remains the same).

https://global.discourse-cdn.com/business7/uploads/djangoproject/original/3X/0/3/03155d774608200be10e574fb64172c6dafa6a38.jpeg

Change History (6)

comment:1 by 梁耀文, 4 months ago

Description: modified (diff)

comment:2 by Natalia Bidart, 4 months ago

Resolution: invalid
Status: newclosed

Hello twFroggen!

Thank you for your report. Please note that the issue you are describing is caused by the English string not having an available translation for the language you are using.
Translations are handled at Transifex, the normal workflow is to translate strings using the Transifex platform (https://explore.transifex.com/django/django-docs/), and then periodically, we fetch the translations from Transifex to put them in this repo.

For more information and help, you can post in the Django Forum.

in reply to:  2 ; comment:3 by 梁耀文, 4 months ago

Replying to Natalia Bidart:
Thank you for your reply. I visited the Transifex website and noticed that, as you mentioned, the zh-Hant translation is not 100% complete. However, I have a question: I found some strings in the Django source code that are present in the .po files, but they are not correctly translated. Why is that?

Hello twFroggen!

Thank you for your report. Please note that the issue you are describing is caused by the English string not having an available translation for the language you are using.
Translations are handled at Transifex, the normal workflow is to translate strings using the Transifex platform (https://explore.transifex.com/django/django-docs/), and then periodically, we fetch the translations from Transifex to put them in this repo.

For more information and help, you can post in the Django Forum.

in reply to:  3 ; comment:4 by Natalia Bidart, 4 months ago

Replying to twFroggen:

Replying to Natalia Bidart:
Thank you for your reply. I visited the Transifex website and noticed that, as you mentioned, the zh-Hant translation is not 100% complete. However, I have a question: I found some strings in the Django source code that are present in the .po files, but they are not correctly translated. Why is that?

Translations are completed by volunteers from our community who donate their time when they can. If you notice any incorrect or missing translations, and if you have the availability to contribute, we encourage you to join the translation team for your language. Please reach out in the Django Forum's Internationalization category to be added to the language team of your choice and help improve these translations.

Thanks!

in reply to:  4 comment:5 by 梁耀文, 4 months ago

Replying to Natalia Bidart:

Replying to twFroggen:

Replying to Natalia Bidart:
Thank you for your reply. I visited the Transifex website and noticed that, as you mentioned, the zh-Hant translation is not 100% complete. However, I have a question: I found some strings in the Django source code that are present in the .po files, but they are not correctly translated. Why is that?

Translations are completed by volunteers from our community who donate their time when they can. If you notice any incorrect or missing translations, and if you have the availability to contribute, we encourage you to join the translation team for your language. Please reach out in the Django Forum's Internationalization category to be added to the language team of your choice and help improve these translations.

Thanks!

I applied a week ago, but I haven't received any response or approval yet. I introduced myself on the Django internationalization forum and applied to join Transifex, but I haven't received any response from either the forum or Transifex. What can I do next to join the translation team?

comment:6 by Claude Paroz, 4 months ago

What can I do next to join the translation team?

Nothing else that being patient :-) You are in the team now.

Note: See TracTickets for help on using tickets.
Back to Top