Opened 5 months ago

Closed 5 months ago

#35178 closed New feature (invalid)

Override FORM_RENDERER for admin site

Reported by: Nikolay Fedorov Owned by: nobody
Component: Forms Version: 5.0
Severity: Normal Keywords: forms, render, template, admin, render template, custom template
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

If I use custom FORM_RENDERER in settings, admin site doesn't work properly. As an example, "Select all" doesn't work becuse I use custom template for select widget.
I want to use Django's default FORM_RENDERER for admin section.

Attachments (1)

Снимок экрана 2024-02-09 в 14.28.59.png (19.4 KB ) - added by Nikolay Fedorov 5 months ago.
select all doesn't work

Download all attachments as: .zip

Change History (2)

by Nikolay Fedorov, 5 months ago

select all doesn't work

comment:1 by Natalia Bidart, 5 months ago

Component: contrib.adminForms
Resolution: invalid
Status: newclosed

Hello Nikolay!

As documented, the FORM_RENDERER setting affects the way that forms and form widgets are rendered. If you wish to have only a subset of forms rendered with your custom renderer, you can follow these docs.

Given the lack of details for this ticket, it seems better suited to be a support request or a new feature request. The best place to get answers to your issue is using any of the user support channels from this link.

Since the goal of this issue tracker is to track issues about Django itself, or new features already discussed and agreed in the forum, I'll be closing this ticket as invalid following the ticket triaging process. If, after debugging, you find out that this is indeed a bug in Django, please re-open with more/specific details and please be sure to include a small Django project to reproduce or a failing test case.

Thank you!

Note: See TracTickets for help on using tickets.
Back to Top