Opened 8 months ago

Closed 7 months ago

Last modified 7 months ago

#35012 closed Bug (fixed)

Wide fieldset fields are hidden.

Reported by: James Gillard Owned by: Tom Carrick
Component: contrib.admin Version: 4.2
Severity: Release blocker Keywords:
Cc: Tom Carrick Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description (last modified by James Gillard)

I've traced a change in how one of our fieldsets that contains 3 wide text inputs displays in the admin. The form fields are overflowing the edge of the page. In the 4.2.8-narrow screenshot, the 3rd is initially completely hidden from view. The UI cannot be scrolled but can be tabbed through. Re-adding this removed line of CSS fixes it for me: https://github.com/django/django/commit/bd0ea8c2ba9943ed245771265f55645dc3bfeae8#diff-ec6643f5575f7b320d2f0f6b342a6ff8d3d5b29e305e6d3b45ca115774012f99L27

This was working on 4.2.7, breaks on 4.2.8, and I've tested main also and see the same visual change. I don't understand the full history of this change hence I'm not suggesting a fix.

Attachments (6)

4.2.7-wide.png (27.8 KB ) - added by James Gillard 8 months ago.
4.2.7-narrow.png (29.7 KB ) - added by James Gillard 8 months ago.
4.2.8-wide.png (20.9 KB ) - added by James Gillard 8 months ago.
4.2.8-narrow.png (17.0 KB ) - added by James Gillard 8 months ago.
repro.png (107.0 KB ) - added by James Gillard 8 months ago.
repro.zip (19.8 KB ) - added by James Gillard 8 months ago.

Download all attachments as: .zip

Change History (22)

by James Gillard, 8 months ago

Attachment: 4.2.7-wide.png added

by James Gillard, 8 months ago

Attachment: 4.2.7-narrow.png added

by James Gillard, 8 months ago

Attachment: 4.2.8-wide.png added

by James Gillard, 8 months ago

Attachment: 4.2.8-narrow.png added

comment:1 by James Gillard, 8 months ago

Description: modified (diff)

comment:2 by James Gillard, 8 months ago

Description: modified (diff)

comment:3 by Natalia Bidart, 8 months ago

Hello James, thank you for your report. Could you please try with the latest stable release, 5.0 and let us know how that goes?

comment:4 by James Gillard, 8 months ago

Hi Natalia, the same issue exists on 5.0.0.

comment:5 by Natalia Bidart, 8 months ago

Thank you James! Could you please provide minimal models.py and admin.py to reproduce the issue?

comment:6 by Natalia Bidart, 8 months ago

Cc: Tom Carrick added

by James Gillard, 8 months ago

Attachment: repro.png added

by James Gillard, 8 months ago

Attachment: repro.zip added

comment:7 by James Gillard, 8 months ago

Here's a zip containing a minimal reproduction, and just the models.py and admin.py files below. The issue is visible with only 2 fields, but I've included 3 as that was what my setup has.

class Foo(models.Model):
    a = models.CharField(max_length=200)
    b = models.CharField(max_length=200)
    c = models.CharField(max_length=200)
@admin.register(Foo)
class FooAdmin(admin.ModelAdmin):
    fieldsets = (
        (
            None,
            {
                "fields": (("a", "b", "c"),),
            },
        ),
    )


comment:8 by Mariusz Felisiak, 8 months ago

Severity: NormalRelease blocker
Triage Stage: UnreviewedAccepted
Version: dev4.2

Thanks for the report! Regression in bd0ea8c2ba9943ed245771265f55645dc3bfeae.

comment:9 by Mariusz Felisiak, 8 months ago

Summary: Admin form visual regressionWide fieldset fields are hidden.

comment:10 by Tom Carrick, 8 months ago

Owner: changed from nobody to Tom Carrick
Status: newassigned

comment:11 by Tom Carrick, 7 months ago

Has patch: set

comment:12 by Tom Carrick, 7 months ago

comment:13 by Mariusz Felisiak, 7 months ago

Triage Stage: AcceptedReady for checkin

comment:14 by Mariusz Felisiak <felisiak.mariusz@…>, 7 months ago

Resolution: fixed
Status: assignedclosed

In 4aae8644:

Fixed #35012 -- Restored wrapping admin fieldsets with multiple fields per line.

Thanks James Gillard for the report.

Regression in 729266c6f29c7a0677b24926a86a767ef3078b26.

comment:15 by Mariusz Felisiak <felisiak.mariusz@…>, 7 months ago

In 8b0710c:

[5.0.x] Fixed #35012 -- Restored wrapping admin fieldsets with multiple fields per line.

Thanks James Gillard for the report.

Regression in 729266c6f29c7a0677b24926a86a767ef3078b26.

Backport of 4aae864463b149393a36e0b18345cf6ed392634d from main

comment:16 by Mariusz Felisiak <felisiak.mariusz@…>, 7 months ago

In ca439908:

[4.2.x] Fixed #35012 -- Restored wrapping admin fieldsets with multiple fields per line.

Thanks James Gillard for the report.

Regression in 729266c6f29c7a0677b24926a86a767ef3078b26.

Backport of 4aae864463b149393a36e0b18345cf6ed392634d from main

Note: See TracTickets for help on using tickets.
Back to Top