Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#34994 closed Bug (fixed)

Visual regression in admin checkboxes on mobile

Reported by: Tom Carrick Owned by: Tom Carrick
Component: contrib.admin Version: 4.2
Severity: Release blocker Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Tom Carrick)

I think it may have been intentional, but it looks pretty wrong.

https://code.djangoproject.com/attachment/ticket/34994/admin-checkboxes.png

Attachments (1)

admin-checkboxes.png (26.8 KB ) - added by Tom Carrick 3 months ago.

Download all attachments as: .zip

Change History (15)

by Tom Carrick, 3 months ago

Attachment: admin-checkboxes.png added

comment:1 by Tom Carrick, 3 months ago

Description: modified (diff)

comment:2 by Mariusz Felisiak, 3 months ago

Owner: changed from nobody to Tom Carrick
Status: newassigned
Triage Stage: UnreviewedAccepted
Type: UncategorizedBug

comment:4 by Tom Carrick, 3 months ago

Triage Stage: AcceptedUnreviewed
Type: BugUncategorized

comment:5 by Tom Carrick, 3 months ago

Triage Stage: UnreviewedAccepted
Type: UncategorizedBug

oops, sorry

comment:6 by Tom Carrick, 3 months ago

comment:7 by Tom Carrick, 3 months ago

Has patch: set

comment:8 by Natalia Bidart, 3 months ago

As per my testing, this is a regression in d687febce5868545f99974d2499a91f81a32fef5 not in b4817d20b9e55df30be0b1b2ca8c8bb6d61aab07.

in reply to:  8 ; comment:9 by Mariusz Felisiak, 3 months ago

Replying to Natalia Bidart:

As per my testing, this is a regression in d687febce5868545f99974d2499a91f81a32fef5 not in b4817d20b9e55df30be0b1b2ca8c8bb6d61aab07.

Are you sure? I checked with Django 4.2.7 and it's centered, it looks fine in Django 4.1.13.

in reply to:  9 ; comment:10 by Natalia Bidart, 3 months ago

Replying to Mariusz Felisiak:

Replying to Natalia Bidart:

As per my testing, this is a regression in d687febce5868545f99974d2499a91f81a32fef5 not in b4817d20b9e55df30be0b1b2ca8c8bb6d61aab07.

Are you sure? I checked with Django 4.2.7 and it's centered, it looks fine in Django 4.1.13.

Yes, I'm sure. I checked out revno d687febce5868545f99974d2499a91f81a32fef5 and the problem is clearly there, and then I checked out the revno right before it (21757bbdcd6ef31f2a4092fa1bd55dff29214c7a) and the check boxes are OK.

d687febce5868545f99974d2499a91f81a32fef5 was backported to 4.2 in revno 788f7b8100dbef050129bf5c1e0af47e7bc89b28

in reply to:  10 comment:11 by Mariusz Felisiak, 3 months ago

d687febce5868545f99974d2499a91f81a32fef5 was backported to 4.2 in revno 788f7b8100dbef050129bf5c1e0af47e7bc89b28

So it's still a release blocker for Django 4.2.

comment:12 by Natalia <124304+nessita@…>, 3 months ago

Resolution: fixed
Status: assignedclosed

In a89c715c:

Fixed #34994 -- Fixed checkbox layout in admin's change page for narrow screen widths.

Regression in d687febce5868545f99974d2499a91f81a32fef5.

comment:13 by Natalia <124304+nessita@…>, 3 months ago

In 4d33816c:

[5.0.x] Fixed #34994 -- Fixed checkbox layout in admin's change page for narrow screen widths.

Regression in d687febce5868545f99974d2499a91f81a32fef5.

Backport of a89c715c3bcf7ab1a90747cf8658ebce6304b6e4 from main

comment:14 by Natalia <124304+nessita@…>, 3 months ago

In bac9e94:

[4.2.x] Fixed #34994 -- Fixed checkbox layout in admin's change page for narrow screen widths.

Regression in d687febce5868545f99974d2499a91f81a32fef5.

Backport of a89c715c3bcf7ab1a90747cf8658ebce6304b6e4 from main

comment:15 by Natalia Bidart, 3 months ago

Triage Stage: AcceptedReady for checkin
Note: See TracTickets for help on using tickets.
Back to Top