Opened 8 years ago

Closed 8 years ago

#3471 closed (duplicate)

Bad error message for misspelled query

Reported by: Dave Abrahams <dave@…> Owned by: adrian
Component: Database layer (models, ORM) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I wrote:

 TimeDivision.objects.filter(when__ge=datetime(2007,5,14))

Note ge instead of gte.

The resulting error was:

  UnboundLocalError: local variable 'new_opts' referenced before assignment

Change History (1)

comment:1 Changed 8 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2348 which has a patch and tests already.

Note: See TracTickets for help on using tickets.
Back to Top