Code

Opened 7 years ago

Closed 7 years ago

#3447 closed (fixed)

Attempt to add new inline-edited item in admin interface results in ProgrammingError ERROR: invalid input syntax for integer: "". Used to work in older SVN snapshot.

Reported by: mdkemp Owned by: adrian
Component: contrib.admin Version: master
Severity: Keywords: edit_inline, ProgrammingError
Cc: mir@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Consider the following extremely-simple inline-edited relationship:

class Case(models.Model):
	name = models.CharField(maxlength=100)

	class Admin:
		pass


class Label(models.Model):
	case = models.ForeignKey(Case, edit_inline=models.TABULAR)
	name = models.CharField(maxlength=100, core=True)

	class Admin:
		pass

In this case, if I try to add a new Label to a Case (while editing the Case via its admin interface view), I get the following error:

Exception Type:  	ProgrammingError
Exception Value: 	ERROR: invalid input syntax for integer: "" SELECT 1 FROM "peopledb_label" WHERE "id"='' LIMIT 1

The following were the arguments from the HTTP POST operation when I clicked Save:

label.0.id     ''
name           'Case1'
label.0.name   'TestLabel1'

It appears that when trying to determine if an old record should be updated rather than inserted into the database, an invalid query was built. I've encountered this problem now on three different django projects. This used to work in a version of django from a SVN snapshot around 12/15/2006, and does work if I revert my installed django to that version.

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 7 years ago by ramiro <rm0 _at_ gmx.net>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I guess this is caused by [4459]

Could you try your test case against r4458 and report back please?

comment:2 Changed 7 years ago by Michael Radziej <mir@…>

  • Cc mir@… added

comment:3 in reply to: ↑ 1 Changed 7 years ago by mdkemp <mdkemp-django@…>

Replying to ramiro <rm0 _at_ gmx.net>:

I guess this is caused by [4459]

Could you try your test case against r4458 and report back please?

Indeed, it worked with r4458 and failed with r4459.

comment:4 Changed 7 years ago by Michael Radziej <mir@…>

  • Triage Stage changed from Unreviewed to Accepted

comment:5 Changed 7 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [4463]) Fixes #3447, Refs #2160 -- Reverting change [4459] because it breaks admin. Apologies for the inconvenience, guys.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.