Code

Opened 7 years ago

Closed 7 years ago

#3423 closed (duplicate)

admin zone error

Reported by: aribao@… Owned by: adrian
Component: Core (Management commands) Version: 0.95
Severity: Keywords: login error
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hello, I'm using django 0.95.1 and I got this error in when I try to log in the admin zone:
Traceback (most recent call last):
File "/var/lib/python-support/python2.4/django/core/handlers/base.py" in get_response

  1. response = callback(request, *callback_args, callback_kwargs)

File "/var/lib/python-support/python2.4/django/contrib/admin/views/decorators.py" in _checklogin

  1. if request.user.is_authenticated() and request.user.is_staff:

File "/var/lib/python-support/python2.4/django/contrib/auth/init.py" in get_user

  1. user_id = request.session[SESSION_KEY]

File "/var/lib/python-support/python2.4/django/contrib/sessions/middleware.py" in getitem

  1. return self._session[key]

File "/var/lib/python-support/python2.4/django/contrib/sessions/middleware.py" in _get_session

  1. self._session_cache = s.get_decoded()

File "/var/lib/python-support/python2.4/django/contrib/sessions/models.py" in get_decoded

  1. encoded_data = base64.decodestring(self.session_data)

TypeError at /admin/
a2b_base64() argument 1 must be string or read-only character buffer, not array.array

I have tested it with python 2.4 and 2.5

Could you help me please?

Thank you.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 7 years ago by ubernostrum

  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening so I can dupe this out.

comment:3 Changed 7 years ago by ubernostrum

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #2335.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.