Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#33971 closed Bug (fixed)

admindocs breaks the admin if it appears before the admin in INSTALLED_APPS

Reported by: Tom Carrick Owned by: Mariusz Felisiak
Component: contrib.admindocs Version: 4.1
Severity: Release blocker Keywords:
Cc: Carlton Gibson, Alokik Roy Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Maxim Danilov)


Change History (8)

comment:1 by Tom Carrick, 21 months ago

Summary: admindocs doesn't work if it appears before the admin in INSTALLED_APPSadmindocs breaks the admin if it appears before the admin in INSTALLED_APPS

comment:2 by Tom Carrick, 21 months ago

Description: modified (diff)

comment:3 by Mariusz Felisiak, 21 months ago

Cc: Carlton Gibson Alokik Roy added
Severity: NormalRelease blocker
Triage Stage: UnreviewedAccepted
Version: dev4.1

Thanks for the report! Unfortunately the proposed solution doesn't fix this for me, so we need to handle it separately.

Regression in 7f3cfaa12b28d15c0ca78bb692bfd6e59d17bff1.

comment:4 by Mariusz Felisiak, 21 months ago

Has patch: set
Owner: changed from nobody to Mariusz Felisiak
Status: newassigned

comment:5 by GitHub <noreply@…>, 21 months ago

Resolution: fixed
Status: assignedclosed

In 974942a7:

Fixed #33955, Fixed #33971 -- Reverted "Fixed #32565 -- Moved internal URLResolver view-strings mapping to admindocs."

This reverts commit 7f3cfaa12b28d15c0ca78bb692bfd6e59d17bff1.

Thanks Tom Carrick and Greg Kaleka for reports.

comment:6 by Mariusz Felisiak <felisiak.mariusz@…>, 21 months ago

In a108380:

[4.1.x] Fixed #33955, Fixed #33971 -- Reverted "Fixed #32565 -- Moved internal URLResolver view-strings mapping to admindocs."

This reverts commit 7f3cfaa12b28d15c0ca78bb692bfd6e59d17bff1.

Thanks Tom Carrick and Greg Kaleka for reports.
Backport of 974942a75039ba43e618f6a5ff95e08b5d5176fd from main

comment:7 by Maxim Danilov, 21 months ago

Description: modified (diff)

This patch war unnecessary.
with the same Effect we can remove method ready from class AdminDocsConfig(AppConfig) from django.contrib.admindocs.apps

For topik starter:
I use many times admindocs in my projects and it was easy solution: to redefine AdminDocsConfig with empty ready method.

in reply to:  7 comment:8 by Mariusz Felisiak, 21 months ago

Replying to Maxim Danilov:

This patch war unnecessary.
with the same Effect we can remove method ready from class AdminDocsConfig(AppConfig) from django.contrib.admindocs.apps

For topik starter:
I use many times admindocs in my projects and it was easy solution: to redefine AdminDocsConfig with empty ready method.

Removing ready() was not a proper solution because admindocs views wouldn't work without it as callbacks wouldn't be registered.

Note: See TracTickets for help on using tickets.
Back to Top