Opened 23 months ago

Closed 23 months ago

Last modified 23 months ago

#33885 closed Cleanup/optimization (duplicate)

Drop automatic PostGIS extension creation on PostGIS backend

Reported by: Johannes Maron Owned by: nobody
Component: GIS Version: 4.0
Severity: Normal Keywords:
Cc: amureki Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Thanks to our friends at Heroku, we currently can't execute create extension without our database throwing an error.

That made us aware of the fact, that the database wrapper for PostGIS execute a SQL statement every time it prepares the database.

That behavior seems inconsistent with how any other PG extension works. Usually, those have to be initialized in a migration explicitly. There has been a debate in the past, if that statement can do any harm, but clearly Heroku has proven it can. Therefore, I would suggest deprecating this behavior and schedule it for deletion in Django 5.

Superseeds #28975

Change History (4)

comment:1 by Johannes Maron, 23 months ago

Keywords: fly.amureki@gmail.com removed

comment:2 by amureki, 23 months ago

Cc: amureki added

comment:3 by Mariusz Felisiak, 23 months ago

Easy pickings: unset
Resolution: duplicate
Status: newclosed

Thanks for the reports, It's definitely a duplicate of #28975 (that we can reopen, if needed).

in reply to:  3 comment:4 by Johannes Maron, 23 months ago

Replying to Mariusz Felisiak:

Thanks for the reports, It's definitely a duplicate of #28975 (that we can reopen, if needed).

Thanks for the swift triage. I didn't feel comfortable to reopen it, since it was about skipping it in Python and I would rather not make the call at all. But I can reopen it and make my case without changing the ticket description.

Note: See TracTickets for help on using tickets.
Back to Top