Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#33720 closed Cleanup/optimization (invalid)

More instructive name in the doc example to help reading

Reported by: Vlada Macek Owned by: nobody
Component: Documentation Version: 4.0
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description (last modified by Vlada Macek)

Changing django_blog to theme_blog to match the class name ThemeBlog will make the example clearer to read.

https://github.com/django/django/blob/19297de2fe5a9c47e471c64249366f39fe12f16a/docs/topics/db/queries.txt#L1378

8 occurrences of the term

Change History (4)

comment:1 Changed 3 months ago by Vlada Macek

Description: modified (diff)

comment:2 Changed 3 months ago by Mariusz Felisiak

Resolution: wontfix
Status: newclosed

In this example we create a theme blog called Django, so django_blog sound appropriate to me.

comment:3 Changed 3 months ago by Mariusz Felisiak

Resolution: wontfixinvalid

comment:4 Changed 3 months ago by Vlada Macek

Respectfully I disagree.

But of course refrain from pushing it further. :-)

I didn't even notice the name value. The class name is IMHO more important to indicate to the new developers.

I raised the ticket, because the inheritance sub-issue discussed in the paragraph was by itself pretty nontrivial for me to comprehend. :-)

Note: See TracTickets for help on using tickets.
Back to Top