Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#33141 closed Cleanup/optimization (fixed)

Rename Aggregate.empty_aggregate_value to empty_result_set_value.

Reported by: David Wobrock Owned by: David Wobrock
Component: Database layer (models, ORM) Version: 4.0
Severity: Normal Keywords: empty_aggregate_value, empty_result_set_value, aggregate, orm, empty
Cc: Simon Charette, Nick Pope, Mariusz Felisiak, David Wobrock Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hi,

In the context of #33018 and a comment on its PR, a suggestion was made to rename Aggregate.empty_aggregate_value to empty_result_set_value

It might even be moved from the Aggregate class to Func to be more general, since in #33018 we define this attribute/property for Coalesce.

Change History (7)

comment:1 by David Wobrock, 2 years ago

Cc: David Wobrock added
Has patch: set
Owner: changed from nobody to David Wobrock

comment:2 by Mariusz Felisiak, 2 years ago

Summary: Rename Aggregate.empty_aggregate_value to empty_result_set_valueRename Aggregate.empty_aggregate_value to empty_result_set_value.
Triage Stage: UnreviewedAccepted

comment:3 by Mariusz Felisiak, 2 years ago

Patch needs improvement: set

comment:4 by David Wobrock, 2 years ago

Patch needs improvement: unset

comment:5 by Mariusz Felisiak, 2 years ago

Triage Stage: AcceptedReady for checkin

comment:6 by Mariusz Felisiak <felisiak.mariusz@…>, 2 years ago

Resolution: fixed
Status: assignedclosed

In ad36a198:

Fixed #33141 -- Renamed Expression.empty_aggregate_value to empty_result_set_value.

comment:7 by Mariusz Felisiak <felisiak.mariusz@…>, 2 years ago

In aab76433:

[4.0.x] Fixed #33141 -- Renamed Expression.empty_aggregate_value to empty_result_set_value.

Backport of ad36a198a12df4dff65992191b3eb0a474e2daac from main

Note: See TracTickets for help on using tickets.
Back to Top