Opened 9 years ago

Closed 9 years ago

#3305 closed defect (duplicate)

Multiple ForeignKeys in same model seems to break inline edits.

Reported by: anonymous Owned by: adrian
Component: Database layer (models, ORM) Version: master
Severity: normal Keywords: ForeignKey ChangeManipulator
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Multiple ForeignKeys in same model seems to break inline edits.

Using the attached models.py with SVN 4325 (and earlier), any attempt to change a profile's GameOfInterests using the "Change Profile" admin form will delete all GameOfInterests from that profile. Furthermore, attempting to change a profile's GameOfInterests via Profile.ChangeManipulator has no effect on GameOfInterests at all. However, changing GameOfInterests via the "Change game of interest" admin form works correctly.

Attachments (1)

models.py (1.8 KB) - added by anonymous 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by anonymous

comment:1 Changed 9 years ago by charlie.sheppard@…

Didn't mean to log this as anonymous. My email is charlie.sheppard@…

comment:2 Changed 9 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #1939.

Note: See TracTickets for help on using tickets.
Back to Top