Opened 4 months ago

Closed 4 months ago

#33032 closed Cleanup/optimization (duplicate)

Document django.shortcuts.resolve_url

Reported by: Sébastien Corbin Owned by: Sébastien Corbin
Component: Documentation Version: 3.2
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Multiple times while training django newcomers and answering SO questions, I found myself incapable of linking a documentation about the (although public) resolve_url function. You can see for yourself : https://docs.djangoproject.com/en/stable/search/?q=resolve_url
I use it mostly in tests (more readable than reverse) or while implementing get_success_url with dynamic arguments.

Hence I searched for tickets mentioning this and could not understand why they were closed https://code.djangoproject.com/ticket/30515

So I'm taking the chance by submitting a PR this time.

Change History (2)

comment:1 Changed 4 months ago by Sébastien Corbin

Has patch: set
Owner: changed from nobody to Sébastien Corbin
Status: newassigned

comment:2 Changed 4 months ago by Mariusz Felisiak

Resolution: duplicate
Status: assignedclosed

Please don't open duplicates and follow the triaging guidelines with regards to wontfix tickets. You can take #30515 to DevelopersMailingList if you don't agree with the previous decision.

Duplicate of #30515.

Note: See TracTickets for help on using tickets.
Back to Top