Opened 8 years ago

Closed 5 years ago

#3298 closed defect (invalid)

max_age doesn't work on mobile phone

Reported by: sten@… Owned by: nobody
Component: Contrib apps Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have been trying to use persistent sessions (cookies) on a mobile phone and never got it to work.
When I change settings.SESSION_EXPIRE_AT_BROWSER_CLOSE = False cookies stops to work on the phone.

After digging down I noticed that it's setting max_age that brakes it on the phone.

When setting expire to desired and max_age=None in process_response (SessionMiddleware) it works.

Regards
Sten

Change History (7)

comment:1 Changed 8 years ago by sten@…

  • Component changed from Admin interface to Contrib apps

comment:2 Changed 8 years ago by mir@…

Hi sten--can you elaborate a bit about this?

  • Do you know why the phone rejects it? Any suspicions? Any further information you found during digging?
  • What phone type did you experience this?

If you could attach a test case that show this behaviour, I would appreciate ;-)

comment:3 Changed 8 years ago by Michael Radziej <mir@…>

Trying again to reach you:

Can you elaborate a bit about this?
Do you know why the phone rejects it? Any suspicions? Any further information you found during digging?
What phone type did you experience this?

If you could attach a test case that show this behaviour, I would appreciate ;-)

comment:4 Changed 8 years ago by anonymous

Hi

I have tested it on Nokia 6680, Nokia N80, Nokia 6280 and I think Sony Ericsson P800 and it's the same on all phones.

Nokia says:

Both Netscape style and W3C HTTP State Management (1.0) cookies are supported. The same cautions regarding expiration and the general availability of local time zone information apply to cookies as well as cache. Also, as with cache, the total space available for storing cookies is limited, so cookie length should be limited to 500 bytes or less where possible.

My guess is that max_age is not set correct according to above.

I have tried the hard way and when setting max_age to None it works between browser launches.

Thanks for checking this out.

Regards
Sten

comment:5 Changed 8 years ago by Michael Radziej <mir@…>

  • Triage Stage changed from Unreviewed to Accepted

Thanks. I'm not sure whether this should be Approved or "Needs Design Decision", but since it looks like a bug, I try "Approved" this time ... let me know if this turns out wrong.

I haven't tried to verify this bug, I don't have any of these phones (or any Nokia), and the rates here are obnoxious, anyway.

@Sten: it might be helpful if you write an email to the django-users group whether there are any users with phone clients.

comment:6 Changed 5 years ago by subsume

  • Triage Stage changed from Accepted to Unreviewed

Closing this ticket. By this point these browsers are considered legacy systems and there's no evidence the problem isn't the legacy software in question.

comment:7 Changed 5 years ago by subsume

  • Resolution set to invalid
  • Status changed from new to closed

err. per above.

Note: See TracTickets for help on using tickets.
Back to Top