Opened 9 months ago

Closed 9 months ago

#32631 closed Bug (duplicate)

Django shows wrong file for NoReverseMatch error

Reported by: Omid Shojaee Owned by: nobody
Component: Template system Version: 3.2
Severity: Normal Keywords: NoReverseMatch
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hello,

In my template I have a reference to an app that doesn't exists yet.

So, Django shows "NoReverseMatch" error — this is what I'm expecting to see.

I'm also expecting to see my template name and line number, however, Django shows line 26 of "base.html" file instead of line 25 of "index.html" file — the latter is where the invalid reference is.

This is happening with all templates that inherited "base.html".

Change History (1)

comment:1 Changed 9 months ago by David Smith

Component: Error reportingTemplate system
Owner: set to nobody
Resolution: duplicate
Status: newclosed

Thank you for the report. This looks like a duplicate of #28935.

Note: See TracTickets for help on using tickets.
Back to Top