Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3256 closed defect (duplicate)

Template login.html moved from registration/ to admin/; update call to loader.

Reported by: Arthur Hebert Owned by: adrian
Component: Contrib apps Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In django/contrib/auth/views.py, the login() method tries to load the template django/contrib/admin/templates/registration/login.html by default. The template file, however, is located in django/contrib/admin/templates/admin/login.html.

The logout() method in the same view points to the same directory and is correct. Perhaps these templates should be in the right place.

I patched this on my server by setting template_name='admin/login.html'. I am not yet sure if that will break anything else.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #516, which was wontfix; The admin is a separate app to the auth app, so they get separate templates. registration/login.html is a suggested default that can be overridden when the login view is used in a URL pattern.

comment:2 Changed 7 years ago by anonymous

  • Keywords 1433 added
  • Version set to 0.90

comment:3 Changed 7 years ago by mir@…

  • Keywords 1433 removed
  • Version 0.90 deleted

Reverted change. Mr. Anonymous, please don't change versions or keywords without reason.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.