Opened 5 months ago

Closed 5 months ago

#32459 closed Bug (duplicate)

Admin inlines not visible on certain screensizes with sidebar open

Reported by: David Smith Owned by: nobody
Component: contrib.admin Version: 3.1
Severity: Normal Keywords:
Cc: Tom Carrick, Carlton Gibson Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by David Smith)

At screen sizes less than or equal to 767px, the admin inlines stack vertically. Above this screen size the sidebar becomes available and is expanded by default, the sidebar takes up extra space and squashes the form input such that it is no longer visible.

Closing the sidebar at 768px is ok, but the screen size needs to be about 950px-1000px before it is usable with the sidebar open.

Unviewable on small screens with sidebar open (768px)
https://code.djangoproject.com/raw-attachment/ticket/32459/inline-768px-open.png

Inputs stack when than 767px or less
https://code.djangoproject.com/raw-attachment/ticket/32459/inline-767px.png

Closing the sidebar at 768px makes it viewable again
https://code.djangoproject.com/raw-attachment/ticket/32459/inline-768px-closed.png

Otherwise the screen size needs to be much larger (img is showing 1000px wide)
https://code.djangoproject.com/raw-attachment/ticket/32459/inline-1000px-open.png

Attachments (5)

inline-767px.png (15.1 KB) - added by David Smith 5 months ago.
inline-768px-closed.png (20.7 KB) - added by David Smith 5 months ago.
inline-768px-closed.2.png (20.7 KB) - added by David Smith 5 months ago.
inline-1000px-open.png (50.7 KB) - added by David Smith 5 months ago.
inline-768px-open.png (48.7 KB) - added by David Smith 5 months ago.

Download all attachments as: .zip

Change History (8)

Changed 5 months ago by David Smith

Attachment: inline-767px.png added

Changed 5 months ago by David Smith

Attachment: inline-768px-closed.png added

Changed 5 months ago by David Smith

Attachment: inline-768px-closed.2.png added

Changed 5 months ago by David Smith

Attachment: inline-1000px-open.png added

Changed 5 months ago by David Smith

Attachment: inline-768px-open.png added

comment:1 Changed 5 months ago by David Smith

Description: modified (diff)

comment:2 Changed 5 months ago by Mariusz Felisiak

Cc: Tom Carrick added
Component: Uncategorizedcontrib.admin
Severity: NormalRelease blocker
Triage Stage: UnreviewedAccepted
Type: UncategorizedBug

Thanks for the report.

Regression in d24ba1be7a53a113d19e2860c03aff9922efec24.
Reproduced at 466920f6d726eee90d5566e0a9948e92b33a122e.

comment:3 Changed 5 months ago by Mariusz Felisiak

Cc: Carlton Gibson added
Resolution: duplicate
Severity: Release blockerNormal
Status: newclosed
Triage Stage: AcceptedUnreviewed

Duplicate of #31576.

I missed that we've already discussed this issue and had decided that shutting the sidebar is sufficient to resolve the issue. However, if you find a way to improve it, we can accept this as cleanup.

Note: See TracTickets for help on using tickets.
Back to Top