Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#323 closed defect (duplicate)

Saving item without making any changes causes a duplicate item to be created in MySQL

Reported by: tmj@… Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When you click on an item in the admin interface, to edit it and then press save without changing any of the data fields a new item is added rather than just saving the data back into the old item.

I am using revision 492.

Change History (5)

comment:1 Changed 10 years ago by ssteiner

This may be the simpler case of ticket #320.

comment:2 Changed 10 years ago by adrian

  • Summary changed from Saving item without making any changes causes a duplicate item to be created. to Saving item without making any changes causes a duplicate item to be created in MySQL

comment:3 Changed 10 years ago by adrian

  • Status changed from new to assigned

comment:4 Changed 10 years ago by adrian

In [506]: Added unit test that tests #323 -- currently fails for MySQL and passes for PostgreSQL.

comment:5 Changed 10 years ago by adrian

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #320.

Note: See TracTickets for help on using tickets.
Back to Top