#32253 closed Bug (duplicate)

Tuple passed instead of string in warnings.warn in validate_key method in base.py

Reported by: kingliar420 Owned by: nobody
Component: Core (Cache system) Version: 3.1
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In validate_key method used for providing warnings if cache key is incompatible with Memcached - a tuple is passed instead of the expected string as an argument to warning.warn as a result it is breaking.

Change History (2)

comment:1 Changed 20 months ago by kingliar420

If this is an actual bug, could I please work on this?

comment:2 Changed 20 months ago by Mariusz Felisiak

Component: UncategorizedCore (Cache system)
Resolution: duplicate
Status: newclosed

Duplicate of #31654. It's already fixed.

Note: See TracTickets for help on using tickets.
Back to Top