Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#32072 closed Bug (fixed)

Search bar input in admin page is out of proportion in Django 3.1.2

Reported by: şuayip üzülmez Owned by: Tom Carrick
Component: contrib.admin Version: 3.1
Severity: Release blocker Keywords:
Cc: Tom Carrick Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

In Django 3.1.2, admin search bar has extra height (most probably because of the unintended/indirect padding rule added in 3.1.2)

Images respectively taken in 3.1.1 and 3.1.2

https://i.imgur.com/oEeH3yO.png
https://i.imgur.com/SnqLv2H.png

Related pull w/ diff:
https://github.com/django/django/commit/8ee4bb6ffcb3346c0fa8fb194986fbf9edadc822#diff-73825862a22f60a0cb787fdc5ddec316L79

Change History (6)

comment:1 Changed 21 months ago by Mariusz Felisiak

Cc: Tom Carrick added
Triage Stage: UnreviewedAccepted

Agreed, it's a small visual regression in 8ee4bb6ffcb3346c0fa8fb194986fbf9edadc822.

comment:2 Changed 21 months ago by Tom Carrick

Owner: changed from nobody to Tom Carrick
Status: newassigned

comment:3 Changed 21 months ago by Tom Carrick

Has patch: set

comment:4 Changed 21 months ago by Mariusz Felisiak

Severity: NormalRelease blocker
Triage Stage: AcceptedReady for checkin

We should backport the fix because it basically restores the previous behavior.

comment:5 Changed 21 months ago by Mariusz Felisiak <felisiak.mariusz@…>

Resolution: fixed
Status: assignedclosed

In 342a417:

Fixed #32072 -- Fixed admin search bar height.

Thanks şuayip üzülmez for the report.

Regression in 8ee4bb6ffcb3346c0fa8fb194986fbf9edadc822.

comment:6 Changed 21 months ago by Mariusz Felisiak <felisiak.mariusz@…>

In 3add635f:

[3.1.x] Fixed #32072 -- Fixed admin search bar height.

Thanks şuayip üzülmez for the report.

Regression in 8ee4bb6ffcb3346c0fa8fb194986fbf9edadc822.

Backport of 342a41740dcfe48a5cd4560c63eeca4d7d41610d from master

Note: See TracTickets for help on using tickets.
Back to Top