Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#32069 closed Bug (fixed)

Admin change form layout broken at narrower browser widths in 3.1.2

Reported by: Phil Gyford Owned by: Benjamin Richter
Component: contrib.admin Version: 3.1
Severity: Release blocker Keywords:
Cc: Tom Carrick Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In Django 3.1.2 the layout of fields and their help text on Admin change form pages breaks down when the browser width is below 768px. It's fine in Django 3.1.1.

Here's a correct example from v3.1.1:

https://i.imgur.com/RscTcwV.png

And here's the same page in v3.2.1:

https://i.imgur.com/1o8FFcm.png

(Both images on imgur.)

I've noticed this on three separate sites I've upgraded to 3.1.2. Downgrading to 3.1.1 corrects the error. I've tried re-running collectstatic and force-reloaded the browser.

Change History (7)

comment:1 Changed 21 months ago by Carlton Gibson

Cc: Tom Carrick added
Severity: NormalRelease blocker
Triage Stage: UnreviewedAccepted

Yep, thanks for the report. Looks like 100% width at the smallest size is affected.

Regression in 8ee4bb6ffcb3346c0fa8fb194986fbf9edadc822

comment:2 Changed 21 months ago by Benjamin Richter

Owner: changed from nobody to Benjamin Richter
Status: newassigned

I will work on this.

comment:3 Changed 21 months ago by Tom Carrick

Hmm I didn't get an email when I was CCd to this, but only when the last message was sent. Is Trac eating emails?

comment:4 Changed 21 months ago by Benjamin Richter

Has patch: set

comment:5 Changed 21 months ago by Carlton Gibson

Triage Stage: AcceptedReady for checkin

comment:6 Changed 21 months ago by Carlton Gibson <carlton@…>

Resolution: fixed
Status: assignedclosed

In 257f8495:

Fixed #32069 -- Fixed admin change-form layout on small screens.

Restored flex-wrap CSS declaration to form elements at smallest breakpoint.
This was present since the responsive admin was introduced in dc37e8846eeedc3a9100ca21fdc9d579bc534c89.
Regression in 8ee4bb6ffcb3346c0fa8fb194986fbf9edadc822, where it was accidentally removed.

comment:7 Changed 21 months ago by Carlton Gibson <carlton.gibson@…>

In b37d5849:

[3.1.x] Fixed #32069 -- Fixed admin change-form layout on small screens.

Restored flex-wrap CSS declaration to form elements at smallest breakpoint.
This was present since the responsive admin was introduced in dc37e8846eeedc3a9100ca21fdc9d579bc534c89.
Regression in 8ee4bb6ffcb3346c0fa8fb194986fbf9edadc822, where it was accidentally removed.

Backport of 257f8495d6c93e30ab0f52af4c488d7344bcf112 from master

Note: See TracTickets for help on using tickets.
Back to Top