Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#31853 closed Bug (fixed)

Incorrect wrapping of translated action labels in admin sidebar for East Asian languages.

Reported by: 007 Owned by: nobody
Component: contrib.admin Version: 3.1
Severity: Release blocker Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: yes

Attachments (3)

.png (5.1 KB) - added by 007 9 months ago.
0.png (5.1 KB) - added by 007 9 months ago.
Screenshot 2020-08-05 at 08.31.55.png (24.7 KB) - added by Carlton Gibson 9 months ago.
Reproduce

Download all attachments as: .zip

Change History (14)

Changed 9 months ago by 007

Attachment: .png added

Changed 9 months ago by 007

Attachment: 0.png added

comment:1 Changed 9 months ago by 007

Has patch: set
Type: UncategorizedBug

comment:2 Changed 9 months ago by Carlton Gibson

Easy pickings: set
Triage Stage: UnreviewedAccepted

Hi. Thanks for the report. It appears that a tweak the CSS would be needed.

comment:3 Changed 9 months ago by Mariusz Felisiak

I cannot reproduce this issue, I don't see any whitespace in the translation 增加 🤔

comment:4 Changed 9 months ago by Carlton Gibson

Description: modified (diff)

Changed 9 months ago by Carlton Gibson

Reproduce

comment:5 Changed 9 months ago by Carlton Gibson

I see it on the sidebar for the list view.

https://code.djangoproject.com/raw-attachment/ticket/31853/Screenshot%202020-08-05%20at%2008.31.55.png

I don't see any whitespace in the translation 增加 🤔

No, there's none, so it's curious. Looking... 👀

comment:6 Changed 9 months ago by Mariusz Felisiak

OK I can reproduce it on Chrome but it works properly on Firefox.

comment:7 Changed 9 months ago by Carlton Gibson

Severity: NormalRelease blocker

comment:9 Changed 9 months ago by Carlton Gibson

Summary: In some languages, such as Chinese, the Add button text of the navigation bar is wrappedIncorrect wrapping of translated action labels in admin sidebar for East Asian languages.
Triage Stage: AcceptedReady for checkin

comment:10 Changed 9 months ago by Carlton Gibson <carlton@…>

Resolution: fixed
Status: assignedclosed

In b0af56f6:

Fixed #31853 -- Fixed wrapping of translated action labels in admin sidebar.

comment:11 Changed 9 months ago by Carlton Gibson <carlton.gibson@…>

In ff8e6e83:

[3.1.x] Fixed #31853 -- Fixed wrapping of translated action labels in admin sidebar.

Backport of b0af56f639179ac5a70253b07ead8b768c4ef4a9 from master

Note: See TracTickets for help on using tickets.
Back to Top