Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#31832 closed New feature (duplicate)

PasswordResetTokenGenerator is difficult to extend

Reported by: Iuri de Silvio Owned by: Iuri de Silvio
Component: contrib.auth Version: dev
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The PasswordResetTokenGenerator is even called default_token_generator but it is not easier to extend because it has a hard coded settings.PASSWORD_RESET_TIMEOUT.

It would be great to reuse this code, just changing _make_hash_value, key_salt and timeout.

Change History (3)

comment:1 Changed 18 months ago by Iuri de Silvio

Owner: changed from nobody to Iuri de Silvio
Status: newassigned

comment:2 Changed 18 months ago by Mariusz Felisiak

Resolution: duplicate
Status: assignedclosed
Type: Cleanup/optimizationNew feature

Duplicate of #30423.

comment:3 Changed 18 months ago by Iuri de Silvio

Thanks! I did not found this ticket on my first research.

Note: See TracTickets for help on using tickets.
Back to Top