Opened 9 months ago

Closed 9 months ago

#31652 closed Uncategorized (invalid)

Admin site URLS do not respect APPEND_SLASH conf

Reported by: Emmanuel Nosa E. Owned by: nobody
Component: contrib.admin Version: 3.0
Severity: Normal Keywords: append, slash, APPEND_SLASH, urls, admin
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Emmanuel Nosa E.)

If this is a design decision, then this ticket can be gracefully closed.

Description

Using the APPEND_SLASH setting, one would expect and does receive the intended behaviour from the configured urls, but to my notice, the admin urls are not respecting this, they append a slash to the end of the url regardless.

Reason

Over here in the django source code (https://github.com/django/django/blob/master/django/contrib/admin/sites.py) for django.contrib.admin.sites, every url within the urlpatterns of the AdminSite.get_urls() ends with a trailing slash. As seen here:

I simply suggest that the APPEND_SLASH setting is respected and the intended urls are returned. In as much as this doesn't hurt, it's an issue within the system, unless like i said earlier;

maybe it's a design decision.

Change History (2)

comment:1 Changed 9 months ago by Emmanuel Nosa E.

Description: modified (diff)

comment:2 Changed 9 months ago by Mariusz Felisiak

Resolution: invalid
Status: newclosed

Please read carefully APPEND_SLASH docs, this setting doesn't affect configured URLs, see also CommonMiddleware docs for more details.

Use one of support channels if you have further questions.

Note: See TracTickets for help on using tickets.
Back to Top