Opened 2 years ago

Closed 2 years ago

#31567 closed Cleanup/optimization (duplicate)

Reversed coordinate order on Ubuntu 20.04.

Reported by: Krzysztof Kulig Owned by: nobody
Component: GIS Version: 3.0
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

After saving a feature with OSMGeoAdmin, the resulting polygon has the following coordinates (a rough area drawn over Berlin, Germany):
SRID=4326;POLYGON ((53.06762663713198 12.23876952954696, 53.35710874043545 14.91943359167391, 51.78143559920171 14.94140624792098, 51.94426487379543 11.79931640460816, 53.06762663713198 12.23876952954696))

Coordinates follow the (latitude, longitude) convention which is reverse of what is expected by PostGIS.

I've tried to run the same project on another Mac OS X environment and there coordinates are correctly saved as longitude/latitude.

There's a chance that it is not a Django issue, but rather GDAL not being fully supported on the latest ubuntu.
gdalinfo --version
GDAL 3.0.4, released 2020/01/28
django==3.0.6

Change History (1)

comment:1 Changed 2 years ago by Mariusz Felisiak

Resolution: duplicate
Status: newclosed
Summary: Reversed coordinate order on Ubuntu 20.04Reversed coordinate order on Ubuntu 20.04.
Type: BugCleanup/optimization

GDAL 3.0 is not supported in Django 3.0. Duplicate of #30678.

Note: See TracTickets for help on using tickets.
Back to Top