#31421 closed Bug (duplicate)

Running test suites hang on mac OX Catalina 10.15.2.

Reported by: Nan Liu Owned by: nobody
Component: Core (Other) Version: dev
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Mariusz Felisiak)

python version is 3.7.3.

i was basically doing "contributing tutorial", and after I have done following:

git clone --depth 1 https://github.com/YourGitHubName/django.git
python -m pip install -e /path/to/your/local/clone/django/
python -m pip install -r requirements/py3.txt
./runtests.py

After I commnad+ c, it shows "Ran 13583 tests in 275.918s", which may indicate the position where it starts hanging.

python version is 3.7.3.

error message after command + c:

FAIL: test_db_table (schema.tests.SchemaTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.7/lib/python3.7/unittest/case.py", line 59, in testPartExecutor
    yield
  File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.7/lib/python3.7/unittest/case.py", line 615, in run
    testMethod()
  File "/Users/nanliu/github/django/django/test/utils.py", line 381, in inner
    return func(*args, **kwargs)
  File "/Users/nanliu/github/django/tests/schema/tests.py", line 2280, in test_db_table
    self.assertForeignKeyExists(Book, "author_id", "schema_otherauthor")
  File "/Users/nanliu/github/django/tests/schema/tests.py", line 201, in assertForeignKeyExists
    self.assertEqual(constraint_fk, (expected_fk_table, field))
  File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.7/lib/python3.7/unittest/case.py", line 839, in assertEqual
    assertion_func(first, second, msg=msg)
  File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.7/lib/python3.7/unittest/case.py", line 1056, in assertTupleEqual
    self.assertSequenceEqual(tuple1, tuple2, msg, seq_type=tuple)
  File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.7/lib/python3.7/unittest/case.py", line 1027, in assertSequenceEqual
    self.fail(msg)
  File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.7/lib/python3.7/unittest/case.py", line 680, in fail
    raise self.failureException(msg)
AssertionError: Tuples differ: ('schema_author', 'id') != ('schema_otherauthor', 'id')

First differing element 0:
'schema_author'
'schema_otherauthor'

- ('schema_author', 'id')
+ ('schema_otherauthor', 'id')
?          +++++

Change History (2)

comment:1 Changed 22 months ago by Nan Liu

Description: modified (diff)

comment:2 Changed 22 months ago by Mariusz Felisiak

Description: modified (diff)
Resolution: duplicate
Status: newclosed
Summary: running test suites hang on mac OX Catalina 10.15.2Running test suites hang on mac OX Catalina 10.15.2.
Type: Cleanup/optimizationBug

Duplicate of #27086, see docs.

Note: See TracTickets for help on using tickets.
Back to Top