#31156 closed Cleanup/optimization (invalid)

Updated seo content not showing on google page when served with django templating

Reported by: Aniket Anand Owned by: nobody
Component: Template system Version: 3.0
Severity: Normal Keywords:
Cc: prashant.parab@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

We have utilized the Django framework to build our site engage4more.com

The site is working well except there is an issue with meta tags.

They are getting populated on the website fine but for some of the pages, the correct tags are not showing in the google results pages.

Example 1- Meta title does not match

This is the google results page when you search for "music fun activities engage4more"

(reference image: https://res.cloudinary.com/dczzp2imu/image/upload/v1578642633/Image-1_zuavg8.jpg)

See the second result. The title tag is "Musical Team Building Activities for Office. - engage4more" when it should be "Musical Team Building Activities like Antakshari for your Office Events" as intended.

The correct title tag in the source of the page -

(reference image: https://res.cloudinary.com/dczzp2imu/image/upload/v1578642637/Image02_tyk35g.jpg)
The above is what should be shown in google search results.

Example 2 - Meta title and description does not match

This is the google results page when you search for "strategy games engage4more"

(reference image: https://res.cloudinary.com/dczzp2imu/image/upload/v1578642641/Image_-_03_v6gr9t.jpg)
The title tag is "Team Building - Activities - engage4more" when it should be "Innovative Strategy Games and Workshops For Office Events " as intended. Also, the meta description is different.

The correct tags in the source of the page -

(reference image: https://res.cloudinary.com/dczzp2imu/image/upload/v1578642645/Image_-_04_iuhg0n.jpg)

The above is what should be shown in google search results.

From the 3 methods mentioned in the below blog, we have used the second method to deploy meta tags on the site:
https://www.vinta.com.br/blog/2015/basic-seo-django/

Also, we have noticed a lot of delays in indexing the pages. In some cases, they are more than 2 weeks.

Please let us know why do you think this is happening and help us with a solution.

Change History (1)

comment:1 Changed 15 months ago by Carlton Gibson

Resolution: invalid
Status: newclosed

Sorry this is not an appropriate ticket for the Django Issue Tracker. See TicketClosingReasons/UseSupportChannels.

Note: See TracTickets for help on using tickets.
Back to Top