Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#308 closed defect (duplicate)

Adding inline-edited related records during _post_save

Reported by: nichyoung Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords: _post_save edit_inline
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I need to add records to a child table in the _post_save and can imagine many other situations where this process would be useful.

This process itself functions as expected; however, when using the admin interface where the child table is edited inline the display of the process fails. I believe the cause of the failure to be an expectation from the admin interface that the added child record would be present on the previous page when it isn't the process fails with a KeyError.

I've made a trivial patch to catch the error and continue but I don't have a sufficiently good understanding of Django to know whether this will cause additional problems.

Attachments (2)

patch (1.4 KB) - added by nichyoung 10 years ago.
Simple patch
patch.2 (755 bytes) - added by nichyoung 10 years ago.
The correct simple patch

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by nichyoung

Simple patch

comment:1 Changed 10 years ago by nichyoung

Oops - added the correct file but from the wrong computer - will try again.

Changed 10 years ago by nichyoung

The correct simple patch

comment:2 Changed 10 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

This will be fixed in the new-admin branch (or shortly after).

Note: See TracTickets for help on using tickets.
Back to Top