#30703 closed Bug (duplicate)

Make RelatedFieldListFilter respect model meta ordering.

Reported by: Sviatoslav Abakumov Owned by: nobody
Component: contrib.admin Version: 2.2
Severity: Normal Keywords: filter
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The Django admin list filter stopped using the model meta ordering after the pull request for #29835 got merged. If there's no ModelAdmin.ordering set, the order of related choices will be reset.

Change History (3)

comment:1 Changed 13 months ago by Sviatoslav Abakumov

comment:2 Changed 13 months ago by felixxm

Summary: Make RelatedFieldListFilter respect model meta orderingMake RelatedFieldListFilter respect model meta ordering.

Thanks for the report, it's a duplicate of #30449. I bumped it to a release blocker.

comment:3 Changed 13 months ago by felixxm

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.
Back to Top