Opened 5 months ago

Closed 5 months ago

#30558 closed Cleanup/optimization (duplicate)

Autocompletion should be disabled in the "Add user" form.

Reported by: Vasili Korol Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords: admin, autocomplete, user
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In the admin:

Home > Authentication and Authorization > Users > Add user

There is a form with a "username", "password" and "password confirmation" input fields. In my case, the browser automatically fills in the first two inputs with my own username and password every time i need to create a new user.

I think the HTML input elements in this form should have autocomplete="off" attribute set.

I observe this in Django 1.11.21. Currently have no possibility to test in newer versions.

I failed to find an existing ticket related to this issue.

Change History (1)

comment:1 Changed 5 months ago by felixxm

Resolution: duplicate
Status: newclosed
Summary: Autocompletion should be disabled in the "Add user" formAutocompletion should be disabled in the "Add user" form.
Type: UncategorizedCleanup/optimization
UI/UX: unset
Version: 1.11master

Thanks for this report, we decided to add autocomplete attributes to contrib.auth fields, that should fix your issue (see #29379).

Duplicate of #29379.

Note: See TracTickets for help on using tickets.
Back to Top