Opened 3 years ago

Closed 3 years ago

#30544 closed Cleanup/optimization (duplicate)

Django 2.1 release notes don't mention the BooleanField(blank=False) default change.

Reported by: Sergei Maertens Owned by: nobody
Component: Documentation Version: 2.1
Severity: Normal Keywords: booleanfield, documentation, release notes
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

In https://github.com/django/django/commit/5fa4f40f45fcdbb7e48489ed3039a314b5c961d0#r30206325 the blank=True default for BooleanField was removed, effectively turning it into blank=False because of the super class. This change is not mentioned in the Django 2.1 release notes.

My tests caught it because I have some introspection going on, I don't think it will break any actual usage, but it left me wondering why that test started failing.

Change History (1)

comment:1 Changed 3 years ago by Mariusz Felisiak

Resolution: duplicate
Status: newclosed
Summary: Django 2.1 release notes don't mention the BooleanField(blank=False) default changeDjango 2.1 release notes don't mention the BooleanField(blank=False) default change.

Thanks for the report. I think we can mark this as a duplicate of #30216.

Note: See TracTickets for help on using tickets.
Back to Top