Opened 2 years ago

Closed 2 years ago

#30464 closed Cleanup/optimization (duplicate)

'AppRegistryNotReady' error after Django Upgrade from 1.8 to 1.11 version

Reported by: vinay Owned by: nobody
Component: Uncategorized Version: 1.11
Severity: Normal Keywords: Django Upgrade, Django-1.11, Django-1.8, AppRegistryNotReady
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In our process of upgrading our Django project from 1.8 to 1.11 version, we removed all the deprecation warnings/errors according to Django-1.11 release notes.
But, after updating the Django version to 1.11 in the project's virtual environment, we got the following error:

raise AppRegistryNotReady("Apps aren't loaded yet.")
django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.

We have many installed apps in the project and using PostgreSQL-9.5 database. We know that the apps which have model classes in it, cause this error to occur.
The above error even occured when connecting to the database using connection cursor:

django.db.connection.cursor().execute()

Change History (1)

comment:1 Changed 2 years ago by Claude Paroz

Resolution: duplicate
Status: newclosed

Duplicate of #30452.

Even if you now use Django 1.11, this is still a support question, not a bug report, unless you can find by debugging that Django is at fault. You should definitely search for help in support channels. And for that, you will also need more information, because without access to your code and at least a full traceback, nobody will be able to help.

Note: See TracTickets for help on using tickets.
Back to Top