#30230 closed Bug (invalid)

GeoDjango installation issue (OSgeo and GDAL versions)

Reported by: hyluo2017 Owned by: nobody
Component: GIS Version: 2.1
Severity: Release blocker Keywords: GeoDjango, OSgeo, GDAL
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

While going through geodjango installation, the part with OSgeo is very tricky. The default OSgeo installation is for GDAL 2.4, while GeoDjango supports up to GDAL 2.2. I've spent two days wrangling with the installation (stackoverflow, etc didn't help much), to little avail. The issue seems to be GDAL_LIBRARY_PATH, but I have a hunch that the problem is version conflict.

I was going to install GDAL2.2, but is facing a need to uninstall GDAL2.4/OSgeo first. There is little instruction on how to uninstall. Need help!

Change History (1)

comment:1 Changed 19 months ago by Tim Graham

Resolution: invalid
Status: newclosed

GDAL 2.4 will probably work fine. No changes were required in b2333426deb1ae9529bed79c1412a9a8046da951. The uninstallation instructions you requested seem out of scope for Django's documentation. You can always ask on the geodjango mailing list. Closing per TicketClosingReasons/UseSupportChannels.

Note: See TracTickets for help on using tickets.
Back to Top