Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#30225 closed Cleanup/optimization (duplicate)

Unicode characters in `migrate` command output making deployment fail

Reported by: Vaibhav Vishal Owned by: nobody
Component: Migrations Version: 2.2
Severity: Normal Keywords: migration, migrate
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When running py manage.py migrate it outputs some unicode characters to the terminal. It is new in 2.2, it was not an issue in 2.1.7
Since There is a unicode character when I deploy the project on AWS Elastic Beanstalk, the migration command fails because it cannot decode the unicode character, please suggest a workaround to avoid this or use ascii characters only to avoid such errors. I have attached the relevant parts of logs of deployment for both 2.1.7(success) and 2.2(fail) to the ticket.

Attachments (2)

2.1.7.log (6.3 KB) - added by Vaibhav Vishal 3 years ago.
Deployment log when using Django==2.1.7, which is successful.
2.2.log (11.1 KB) - added by Vaibhav Vishal 3 years ago.
Deployment log when using Django==2.2, which failed.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Vaibhav Vishal

Attachment: 2.1.7.log added

Deployment log when using Django==2.1.7, which is successful.

Changed 3 years ago by Vaibhav Vishal

Attachment: 2.2.log added

Deployment log when using Django==2.2, which failed.

comment:1 Changed 3 years ago by Vaibhav Vishal

Summary: Unicode characters in `migrate` command outputUnicode characters in `migrate` command output making deployment fail

comment:2 Changed 3 years ago by Simon Charette

Resolution: duplicate
Status: newclosed

Duplicate of #30184 fixed in 5e94c817ee26a13e141a11a2f429f9ee2cc37ab0 which should be part of the upcoming 2.2 release.

comment:3 Changed 3 years ago by Carlton Gibson

Also though, a quick Google leads to this AWS page suggesting you can set a decent locale in your application to fix this properly.

https://forums.aws.amazon.com/thread.jspa?threadID=221739

comment:4 Changed 3 years ago by Vaibhav Vishal

Thanks for the aws forums link. It solved my problem. I did searched on google for the problem but couldn't find anything, sorry for creating a ticket.

Note: See TracTickets for help on using tickets.
Back to Top