Opened 5 months ago

Closed 5 months ago

#30007 closed Bug (duplicate)

ForeignKey's limit_choices_to attribute is ignored when autocomplete view builds queryset.

Reported by: Mehdi Pourfar Owned by: nobody
Component: contrib.admin Version: 2.1
Severity: Normal Keywords: admin, autocomplete, limit_choices_to
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When I set limit_choices_to on a ForeignKey field, and set my admin model to use autocomplete for that field, my limit_choices_to is ignored in autocomplete results.

Change History (1)

comment:1 Changed 5 months ago by Simon Charette

Resolution: duplicate
Status: newclosed

Duplicate of #29707.

Note: See TracTickets for help on using tickets.
Back to Top