Opened 10 years ago

Closed 10 years ago

#2997 closed defect (fixed)

[patch] Changeset [4037] broke URLField

Reported by: jkocherhans Owned by: adrian
Component: Validators Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

[4037] still uses the field_data variable name instead of value which breaks URLField's convert method. Adding to the problem is the bare except at line 222 of [source:/django/trunk/django/newforms/fields.py#4037#L222 fields.py] which masks the real problem. Changing the bare except to catch urllib2.URLError fixes the tests, though I'm not sure that it will catch everything it's meant to though.

Attachments (1)

URLField.diff (767 bytes) - added by jkocherhans 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by jkocherhans

comment:1 Changed 10 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

(In [4061]) Fixed #2997 -- Fixed URLField validation in django.newforms. Thanks, jkocherhans

Note: See TracTickets for help on using tickets.
Back to Top