Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#29729 closed Bug (fixed)

Update contributing tutorial to recommend running tests on master

Reported by: Adam Johnson Owned by: Adam Johnson
Component: Documentation Version: 2.1
Severity: Normal Keywords:
Cc: Adam Johnson Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

As discussed recently on the django-core-mentorship list (link for those who can see it: https://groups.google.com/d/msg/django-core-mentorship/SawVLIt2ntk/MvuwLUaUAwAJ ), there are some test failures now when following the "Rolling back to a previous revision of Django" section of this tutorial. The reporter found failures with a new GEOS version (for an issue fixed on django master a year ago), and I found test failures with Python 3.7 because the given commit is from Django 1.9.

I suggest two changes:

  • Encourage running the test suite on master before hitting this section - any commit we pick to 'roll back to' is going
  • Update to a recent commit and ticket

Change History (8)

comment:1 Changed 4 years ago by Adam Johnson

Cc: Adam Johnson added
Owner: changed from nobody to Adam Johnson
Status: newassigned

I suspect moving to a later commit isn't a great idea as it'll just be a moving target. I suggest instead some kind of "fake feature" in the tutorial to implement, such as adding a new function to django.init. This would also require less knowledge of the specifics of whatever real tickets are touching, e.g. the current one is a fairly niche forms feature. Thoughts anyone?

comment:2 Changed 4 years ago by Carlton Gibson

Triage Stage: UnreviewedAccepted
Type: UncategorizedBug

The tutorial: Writing your first patch for Django.

One option would be to provide a pinned set of requirements, so that users create a virtualenv in a a known state, compatible with the ticket/Django commit picked.

Last edited 4 years ago by Carlton Gibson (previous) (diff)

comment:3 Changed 4 years ago by Adam Johnson

Sure. It would be a lot of requirements though, and other bitrot can still take place like Python and Pip versions incompatibilities.

comment:4 Changed 4 years ago by Carlton Gibson

Yes, as you say. 🙂

  • Happy for you to suggest what you think is best.
  • Not sure ‘'anything’’ would survive without maintanence indefinitely.

comment:5 Changed 4 years ago by Tim Graham

Has patch: set
Summary: Update "Writing your first patch for Django" tutorialUpdate contributing tutorial to recommend running tests on master
Triage Stage: AcceptedReady for checkin

Updating to a more recent commit and ticket is a duplicate of #28034.

PR from Adam for the first change.

comment:6 Changed 4 years ago by Tim Graham <timograham@…>

Resolution: fixed
Status: assignedclosed

In f8ff529e:

Fixed #29729 -- Updated contributing tutorial to run tests on master.

comment:7 Changed 4 years ago by Tim Graham <timograham@…>

In 2b2474b:

[2.1.x] Fixed #29729 -- Updated contributing tutorial to run tests on master.

Backport of f8ff529ee32c79b270176f5e8d7a3f6ef048ac31 from master

comment:8 Changed 4 years ago by Adam Johnson

Thanks Tim! 🧠

Note: See TracTickets for help on using tickets.
Back to Top