Opened 4 years ago

Closed 4 years ago

#29670 closed Bug (duplicate)

Django 2.1 PDF and ePub documentation download links are broken.

Reported by: Yaroslav Nikitenko Owned by: nobody
Component: Documentation Version: 2.1
Severity: Normal Keywords: pdf
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When I open
https://docs.djangoproject.com/en/2.1/

the link to download pdf
https://media.readthedocs.org/pdf/django/2.1.x/django.pdf
is broken.

On RTD I see last numbered version in the menu as 2.0
https://django.readthedocs.io/en/stable/

P.S. I've already sent a similar bug on earlier an version's documentation pdf (hope that was fixed, but the problem seems to be recurring).
P.P.S. Sorry, the ticket is already opened 9 days ago.
https://code.djangoproject.com/ticket/29638
However, I can't see whether I should create the same ticket or somehow join the existing ticket.
https://docs.djangoproject.com/en/dev/internals/contributing/bugs-and-features/#reporting-bugs
Hope that will be fixed.

Change History (8)

comment:1 Changed 4 years ago by Jeff

FWIW, I confirmed the link is broken.

comment:2 Changed 4 years ago by Jeff

Triage Stage: UnreviewedAccepted

comment:3 Changed 4 years ago by Jeff

the .epub also goes to a 404 for me.

comment:4 Changed 4 years ago by Jeff

Summary: Django 2.1 documentation pdf missingDjango 2.1 PDF and ePub documentation download links are broken.

comment:5 Changed 4 years ago by Jeff

Duplicate of #29638. I will reference it there.

comment:6 in reply to:  5 Changed 4 years ago by Yaroslav Nikitenko

Thank you.
How should I better act in these cases, when the ticket already exists (but not fixed)?
Replying to Jeff:

Duplicate of #29638. I will reference it there.

comment:7 Changed 4 years ago by Jeff

I'd recommend leaving a comment on that ticket to raise awareness that it is still open and affecting users (you).

comment:8 Changed 4 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

This must be resolved by readthedocs staff: https://github.com/rtfd/readthedocs.org/issues/4519

Note: See TracTickets for help on using tickets.
Back to Top