Opened 2 years ago

Last modified 2 years ago

#29640 new Cleanup/optimization

Document (deprecate?) Paginator._get_page

Reported by: Josh Schneier Owned by: nobody
Component: Core (Other) Version: 2.1
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

This has been undocumented since it was introduced in ~1.6 although it is meant for public use to override the Page class used by a Paginator.

Assuming we keep it (is anyone using it?) I think I like something along the approach of the generic views. We could add a get_page_class method and a page_class attribute although I wonder if the latter isn't enough. We'd need the former to maintain feature parity.

Change History (3)

comment:1 Changed 2 years ago by Josh Schneier

Component: UncategorizedCore (Other)
Type: UncategorizedCleanup/optimization

comment:2 Changed 2 years ago by Carlton Gibson

Triage Stage: UnreviewedAccepted

Moving to get_page_class() plus page_class seems reasonable.

  • I know it's not public but maybe we should deprecate _get_page(), since it's been around a while. (Tim?)
  • If so, there's a slight wiggle: _get_page() returns the instance where get_page_class() would presumably give us the class, which we then instantiate in page().

Not sure whether just having the attribute would be enough? Maybe someone is customising for first or last page, as one thought. We may as well leave it available (rather than needing to re-add it later.)

comment:3 Changed 2 years ago by Josh Schneier

I regret suggesting get_page for the piece where we inlined the docs now. Maybe something like get_safe_page would have been better. That is a minor issue, I do wonder if that particular aspect of the functionality is used.

Note: See TracTickets for help on using tickets.
Back to Top