Opened 8 years ago

Closed 8 years ago

#2960 closed defect (duplicate)

edit_inline regressed, no longer using custom templates

Reported by: Yary Owned by: adrian
Component: contrib.admin Version: 0.95
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

See this post to the usergroups.

I just ran into the same problem, and it took over an hour to track it down.

Seems that I could once sublcass BoundRelatedObject, and set edit_inline=MySubclass, and get custom behavior. Now seems that don't work no more.

Suggestion, change admin_modify.py 'EditInlineNode' to read, in part,

        if relation.field.rel.edit_inline == models.TABULAR: 
            bound_related_object_class = TabularBoundRelatedObject 
        elif relation.field.rel.edit_inline == models.STACKED: 
            bound_related_object_class = StackedBoundRelatedObject
        else: bound_related_object_class = relation.field.rel.edit_inline

Change History (1)

comment:1 Changed 8 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2508 and already fixed in [3801].

Note: See TracTickets for help on using tickets.
Back to Top