Opened 9 years ago

Closed 9 years ago

#2953 closed defect (invalid)

'django-manage.py sqlall auth'/'python manage.py syncdb' keeps trying to install tables

Reported by: anonymous Owned by: adrian
Component: Core (Management commands) Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This is really bizarre, and hopefully there's a simple answer I've missed. Each time I try to run 'python manage.py syncdb' to update the app's tables, it tries to create the tables for the auth module. Even though they're already created. I've poured through the source, and can't figure out what the problem is.

The error message suggests running 'django-manage.py sqlall auth', which I do. But all it does is output the commands to create the tables used by auth, which it shouldn't be doing. It's not giving me any hints why it doesn't see that the app is already installed.

This is on RHEL 3.0, using Python 2.4 and Django 0.95. The db is MySQL 5.0.26.

My bash environment is:
BASH=/bin/bash
BASH_ARGC=()
BASH_ARGV=()
BASH_LINENO=()
BASH_SOURCE=()
BASH_VERSINFO=([0]="3" [1]="00" [2]="15" [3]="1" [4]="release" [5]="i386-redhat-linux-gnu")
BASH_VERSION='3.00.15(1)-release'
COLORS=/etc/DIR_COLORS.xterm
COLUMNS=80
CVSROOT=/usr/local/cvsroot
DIRSTACK=()
DISPLAY=localhost:14.0
DJANGO_SETTINGS_MODULE=mywriting.settings
EUID=500
GROUPS=()
G_BROKEN_FILENAMES=1
HISTFILE=/home/obfuscatedusername/.bash_history
HISTFILESIZE=1000
HISTSIZE=1000
HOME=/home/obfuscatedusername
HOSTNAME=obfuscatedhost
HOSTTYPE=i386
IFS=$' \t\n'
INPUTRC=/etc/inputrc
KDEDIR=/usr
LANG=en_US.UTF-8
LESSOPEN='|/usr/bin/lesspipe.sh %s'
LINES=24
LOGNAME=obfuscatedusername
LS_COLORS='no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:'
MACHTYPE=i386-redhat-linux-gnu
MAIL=/var/spool/mail/obfuscatedusername
MAILCHECK=60
OLDPWD=/home/obfuscatedusername/download/mysql5
OPTERR=1
OPTIND=1
OSTYPE=linux-gnu
PATH=/bin:/usr/bin:/usr/X11R6/bin:/home/obfuscatedusername/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/sbin
PIPESTATUS=([0]="0" [1]="0")
PPID=3941
PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\007"'
PS1='[\u@\h \W]\$ '
PS2='> '
PS4='+ '
PWD=/home/obfuscatedusername/projects/mywriting
PYTHONPATH=:/home/obfuscatedusername/projects
SHELL=/bin/bash
SHELLOPTS=braceexpand:emacs:hashall:histexpand:history:interactive-comments:monitor
SHLVL=1
SUPPORTED=en_US.UTF-8:en_US:en
TERM=xterm
USER=obfuscatedusername
_=

Change History (1)

comment:1 Changed 9 years ago by russellm

  • Resolution set to invalid
  • Status changed from new to closed

The ticket system is for identifiable bugs, not problem solving. Please ask this question on the mailing list; if it turns out this is an actual problem we can reopen the ticket.

Note: See TracTickets for help on using tickets.
Back to Top