Opened 3 years ago

Closed 3 years ago

#29512 closed Cleanup/optimization (duplicate)

QuerySet pipe operator is undocumented

Reported by: Colm O'Connor Owned by: nobody
Component: Documentation Version: 2.0
Severity: Normal Keywords:
Cc: Adam Johnson Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Q(x) | Q(y) is documented although combining two querysets using pipe (|) is apparently not.

Change History (3)

comment:1 Changed 3 years ago by Adam Johnson

Cc: Adam Johnson added

comment:2 Changed 3 years ago by Adam Johnson

git blame takes me back to "MERGED MAGIC-REMOVAL BRANCH TO TRUNK" ( https://github.com/django/django/commit/f69cf70ed813a8cd7e1f963a14ae39103e8d5265 ), so it has been there from the early days and it's less surprising it's undocumented.

There's also qs1 & qs2 which probably needs documenting too.

comment:3 Changed 3 years ago by Tim Graham

Resolution: duplicate
Status: newclosed
Type: UncategorizedCleanup/optimization

Duplicate of #21333.

Note: See TracTickets for help on using tickets.
Back to Top