Opened 4 months ago

Closed 4 months ago

#29489 closed Bug (duplicate)

Shell and default language preference

Reported by: Peyman Karimi Owned by: nobody
Component: Internationalization Version: 2.0
Severity: Normal Keywords: shell, LANGUAGE_CODE, USE_I18N
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When we run the django shell (./manage.py shell), the default language code (settings.LANGUAGE_CODE) is not activated by default (settings.USE_I18N is set to True) and user has to activate it manually by performing something like this:

from django.conf import settings
from django.utils import translation; translation.activate(settings.LANGUAGE_CODE)

Change History (2)

comment:1 Changed 4 months ago by Sergey Fedoseev

Duplicate of #17379?

comment:2 Changed 4 months ago by Claude Paroz

Resolution: duplicate
Status: newclosed

I think Serguey is right. Would be nice to have your feedback with this on Django 2.1.

Note: See TracTickets for help on using tickets.
Back to Top