Opened 7 months ago

Closed 7 months ago

#29300 closed Cleanup/optimization (duplicate)

Allow overriding INTERNAL_RESET_URL_TOKEN on PasswordResetConfirmView

Reported by: Mateusz Kurowski Owned by: nobody
Component: contrib.auth Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

Built in password reset view is really cool, but i don't understand why these things are hard coded:

https://github.com/django/django/blob/aeb8c381789ad93866223f8bd07d09ae5e2edd9e/django/contrib/auth/views.py#L237

I am not sure what "easy pickings" mean but its an easy thing so i selected that option.
Fix looks really trivial:

https://github.com/django/django/pull/9859

Change History (1)

comment:1 Changed 7 months ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #28780.

Note: See TracTickets for help on using tickets.
Back to Top