Code

Opened 8 years ago

Closed 7 years ago

#2919 closed defect (duplicate)

ReferenceError? at / weakly-referenced object no longer exists

Reported by: dcramer@… Owned by: adrian
Component: Database layer (models, ORM) Version:
Severity: major Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

We just moved Django from a BSD server to a Fedora Core linux install. This error randomly pops up and you can refresh to get rid of it.

I'm assuming this is a framework issue and not something we're doing as it happens throughout the site (not on any specific view/app)

Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/django/core/handlers/base.py" in get_response

  1. response = callback(request, *callback_args, callback_kwargs)

File "/home/www/cursedjango/cursesite/../cursesite/articles/views.py" in index

  1. return render_to_response('index.html', context_instance=context)

File "/usr/lib/python2.4/site-packages/django/shortcuts/init.py" in render_to_response

  1. return HttpResponse(loader.render_to_string(*args, kwargs))

File "/usr/lib/python2.4/site-packages/django/template/loader.py" in render_to_string

  1. return t.render(context_instance)

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render

  1. return self.nodelist.render(context)

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render

  1. bits.append(self.render_node(node, context))

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render_node

  1. return(node.render(context))

File "/usr/lib/python2.4/site-packages/django/template/loader_tags.py" in render

  1. return compiled_parent.render(context)

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render

  1. return self.nodelist.render(context)

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render

  1. bits.append(self.render_node(node, context))

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render_node

  1. return(node.render(context))

File "/usr/lib/python2.4/site-packages/django/template/loader_tags.py" in render

  1. result = self.nodelist.render(context)

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render

  1. bits.append(self.render_node(node, context))

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render_node

  1. return(node.render(context))

File "/usr/lib/python2.4/site-packages/django/template/defaulttags.py" in render

  1. return self.nodelist_true.render(context)

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render

  1. bits.append(self.render_node(node, context))

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render_node

  1. return(node.render(context))

File "/usr/lib/python2.4/site-packages/django/template/defaulttags.py" in render

  1. nodelist.append(node.render(context))

File "/usr/lib/python2.4/site-packages/django/template/init.py" in render

  1. dict = func(*args)

File "/home/www/cursedjango/cursesite/../cursesite/ratings/templatetags/ratings.py" in show_rating

  1. content_type = ContentType.objects.get(app_labelexact=appargs[0], modelexact=appargs[1])

File "/usr/lib/python2.4/site-packages/django/db/models/manager.py" in get

  1. return self.get_query_set().get(*args, kwargs)

File "/usr/lib/python2.4/site-packages/django/db/models/query.py" in get

  1. obj_list = list(clone)

File "/usr/lib/python2.4/site-packages/django/db/models/query.py" in iter

  1. return iter(self._get_data())

File "/usr/lib/python2.4/site-packages/django/db/models/query.py" in _get_data

  1. self._result_cache = list(self.iterator())

File "/usr/lib/python2.4/site-packages/django/db/models/query.py" in iterator

  1. cursor.execute("SELECT " + (self._distinct and "DISTINCT " or "") + ",".join(select) + sql, params)

File "/usr/lib/python2.4/site-packages/django/db/backends/util.py" in execute

  1. return self.cursor.execute(sql, params)

File "/usr/lib/python2.4/site-packages/django/db/backends/mysql/base.py" in execute

  1. return self.cursor.execute(sql, params)

File "/usr/lib/python2.4/site-packages/MySQLdb/cursors.py" in execute

  1. self.errorhandler(self, exc, value)

File "/usr/lib/python2.4/site-packages/MySQLdb/connections.py" in defaulterrorhandler

  1. raise errorclass, errorvalue

ReferenceError at /
weakly-referenced object no longer exists

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by mtredinnick

Which web server interface are you using: development server, mod_python or wsgi?

comment:2 Changed 8 years ago by anonymous

lighttpd w/ fastcgi

comment:4 Changed 7 years ago by dcramer@…

http://web.t-online.hu/oro18/error.html

Wish I could change this to critical, as something that prevents a user from viewing the site randomly (seems to be on session creation) has become a major issue.

comment:5 Changed 7 years ago by Simon G. <dev@…>

  • Summary changed from DB Api Issues to ReferenceError? at / weakly-referenced object no longer exists
  • Version SVN deleted

Does this problem still exist? Can anyone provide more information?

comment:6 Changed 7 years ago by David Cramer <dcramer@…>

This was related to lighttpd and threaded mode.. I believe, our solution: use Apache with its enormous memory overhead.

comment:7 Changed 7 years ago by mir@…

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #3279 (but there with apache/fastcgi/threaded).

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.