Opened 3 years ago

Closed 3 years ago

#29070 closed Bug (invalid)

Admin login redirects to /accounts/login after upgrade to Django 2.0

Reported by: Dan Loewenherz Owned by: nobody
Component: contrib.admin Version: 2.0
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Dan Loewenherz)

After upgrading to Django 2.0, our administrative site login redirects to the site-wide login URL (/accounts/login) instead of the admin login. This seems like a bug.

LOGIN_URL and LOGOUT_URL are both default, and path('admin/', admin.site.urls), is the first URL listed in urlpatterns.

If this is a known issue, great, if not, let me know and I will try to get a reproducible test case.

Change History (3)

comment:1 Changed 3 years ago by Dan Loewenherz

Description: modified (diff)

comment:2 Changed 3 years ago by Tim Graham

No, I haven't seen a report like this.

comment:3 Changed 3 years ago by Dan Loewenherz

Resolution: invalid
Status: newclosed

This issue is due to a third-party app (django-two-factor-auth) overriding the login routes. Closing.

Note: See TracTickets for help on using tickets.
Back to Top