Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#28941 closed Bug (fixed)

testserver crashes due to runserver shutdown_message option

Reported by: peter-rci Owned by: Tim Graham
Component: Testing framework Version: 2.0
Severity: Release blocker Keywords: testserver
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

I believe the testserver command cannot be used at all in Django 2.0. Here are lines 47-54 from testserver.py:

        call_command(
            'runserver',
            addrport=options['addrport'],
            shutdown_message=shutdown_message,
            use_reloader=False,
            use_ipv6=options['use_ipv6'],
            use_threading=use_threading
        )

Removing the shutdown_message=shutdown_message line fixes the problem.

Change History (4)

comment:1 Changed 3 years ago by Tim Graham

Owner: changed from nobody to Tim Graham
Severity: NormalRelease blocker
Status: newassigned
Summary: testserver invokes runserver shutdown_message option, which does not existtestserver crashes due to runserver shutdown_message option
Triage Stage: UnreviewedAccepted

comment:2 Changed 3 years ago by Tim Graham

Has patch: set

comment:3 Changed 3 years ago by Tim Graham <timograham@…>

Resolution: fixed
Status: assignedclosed

In e7b804c0:

Fixed #28941 -- Fixed crash in testserver command startup.

Regression in 2b09e4c88e96cb03b29f5a6b0e4838ab4271e631.

comment:4 Changed 3 years ago by Tim Graham <timograham@…>

In 6f86d8bc:

[2.0.x] Fixed #28941 -- Fixed crash in testserver command startup.

Regression in 2b09e4c88e96cb03b29f5a6b0e4838ab4271e631.

Backport of e7b804c060a1f9fc089cf935801aa85b09db062b from master

Note: See TracTickets for help on using tickets.
Back to Top