Opened 3 years ago

Closed 3 years ago

#28812 closed New feature (duplicate)

Lack of ModelAdmin permission to list all objects.

Reported by: Wojciech Kokorzycki Owned by: nobody
Component: contrib.admin Version: 1.11
Severity: Normal Keywords: permissions
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Listing all objects permission is connected to permission called: "has_change_permission". There is missing permission for listing all objects that we have permissions.

I suggest name as:
"has_list_permission"
It could take argument whether to display all objects or only these that has_change_permission returns True (sounds as default option), but also has_delete_permission and has_add_permission should be taken under consideration.

Change History (1)

comment:1 Changed 3 years ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #8936 "Add view (read-only) permission to admin".

Note: See TracTickets for help on using tickets.
Back to Top